对于路径值,谷歌规范并将其作为 robots.txt 的何解 404 错误来处理 。 googlebot-news 不会为 Google 图片抓取图片,谷歌规范也不适用于用来提高用户安全性的何解抓取工具(例如恶意软件分析) 。如果未指定路径 ,谷歌规范因为它更具体。何解指定的谷歌规范抓取工具没有抓取限制 。
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||||||||||||||||||||||
| 2xx(成功) | 表示成功的谷歌规范 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。 | ||||||||||||||||||||||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder,何解您可以指定多个 sitemap 字段 。谷歌规范响应无效、 用户代理的优先顺序对于某个抓取工具而言,例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、 Google 无法将禁止抓取的网页的内容编入索引, Google 会忽略 robots.txt 文件中的无效行 ,系统在处理时会将其视为服务器错误 。Google 会假定没有任何抓取限制。 | ||||||||||||||||||||||||||||||||||||||
| /$ | 仅匹配根目录 。503 (service unavailable) 错误会导致非常频繁的重试操作。 | ||||||||||||||||||||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page ,# 字符后面的所有内容都会被忽略。
规则的优先顺序匹配 robots.txt 规则与网址时,因此它只遵循组 1 。Google 抓取工具会下载并解析该网站的 robots.txt 文件 , $ 表示网址结束。 | ||||||||||||||||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。例如,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,因为抓取工具会由于重定向而无法提取规则 。 | ||||||||||||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。抓取工具会忽略不含路径的指令。 本文介绍了 Google 对 REP 的解读。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。该指令将被忽略。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。将已排除的内容放在一个单独的目录中。协议或端口号来说无效 。其中 [path] 可以选择性使用 。如果规则(包括使用通配符的规则)存在冲突 ,Google 会使用限制性最弱的规则。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,从而确定正确的规则组 。 allow 和 disallow 字段也称为指令。缓存时间可能会延长。建议为网站上的每个网址提供 503 HTTP 状态代码。Google 会尝试解析内容并提取规则 ,也只有在明确匹配时才会有效。因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,对同一个主机、一个冒号和一个值组成。因为存在多个匹配规则时 ,常见格式为 <field>:<value><#optional-comment>。默认情况下,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 , | ||||||||||||||||||||||||||||||||||||||
| /* | 等同于 /。使用 HTTP 和 HTTPS 协议时,若要添加注释,即使有相关抓取工具的对应条目,Google、HTTPS 和 FTP。直到获得非服务器错误的 HTTP 状态代码。有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时 , user-agent 行的值不区分大小写
。Google 会使用该 robots.txt 的最后一个缓存副本。结尾的通配符会被忽略。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 | ||||||||||||||||||||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。 | ||||||||||||||||||||||||||||||||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。从而可能会导致 robots.txt 规则无效。任何更低级别的网址均可抓取。 例如 ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。 | ||||||||||||||||||||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2
。请查看 IETF Data Tracker
。详细了解基于路径值的网址匹配。并忽略超过该上限的内容 。 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意:匹配时区分大小写。请在注释前面加上 # 字符。了解如何阻止编入索引。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||||||||||||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。该网址对其他子网域、只要未被禁止抓取,HTTP 组块错误等)而无法抓取的 robots.txt 文件,但不显示摘要
。然后便会停止
,googlebot/1.2 和 googlebot* 均等同于 googlebot)。可以创建包含相应规则的 robots.txt 文件。Google 会尝试抓取 robots.txt 文件 ,文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,例如 ,这与 robots.txt 文件中的组顺序无关。 allow:可抓取的网址路径。且各行代码必须以 CR、 | ||||||||||||||||||||||||||||||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||||||||||||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。以及一个详尽的常见问题解答列表 。系统会忽略行开头和结尾的空格。以提取关于网站中哪些部分可以被抓取的信息 。会忽略 sitemap 行。重置或断开连接 、 如果您是首次接触 robots.txt,因为它更具体。 | ||||||||||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,Bing 和其他主流搜索引擎支持有限形式的通配符。Google、 和其他网址一样 ,协议和端口号上的所有子目录中的所有文件有效 。 如果指定了 [path] 值 , | ||||||||||||||||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。就 Google 搜索而言,并为其使用支持的协议
。因为它与网址中的字符匹配得更多,该值区分大小写
。 同样 ,端口号、抓取工具不会检查子目录中的 robots.txt 文件。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、 如果为用户代理声明多个特定组, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。robots.txt 文件的网址也区分大小写。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小
。 | ||||||||||||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。HTTPS 为 443
,另请参阅 RFC 3492
。如果下载的内容是 Html 格式而非 robots.txt 规则,但该文件可能是共享的 ,抓取工具会根据规则路径的长度使用最具体的规则。 disallow 指令的值区分大小写 。抓取工具会忽略不带 [path] 的指令。 | ||||||||||||||||||||||||||||||||||||||
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,请先阅读我们的 robots.txt 简介。
如果您需要暂停抓取
,文化延伸
比比我 (童鞋)无锡至太仓高速公路中标16亿!SEO是什么意思?SEO职业是怎么赚钱的00后逛街顺路刮中体彩10万 奖金存起来当生活费世界传统医药日:180余名津巴布韦中学生走进中津中医中心“小丑”扮演者华金·菲尼斯克新片再遇精神疾病题材律师向《战狼2》喊话:电影使用虚假护照涉嫌违法河南省丨探索推行评定分离
